PowCalc

 最小化 关闭（或终止进程） 标题栏 关于 PowCalc (等价键盘操作：F1 | Shift+"?") 左对齐(等价键盘操作：Tab) 右对齐(等价键盘操作：Tab) 复制数据到剪贴板(等价键盘操作：Ctrl+C) 与剪贴板上数据比较(等价键盘操作：Ctrl+K) 查看结果(等价键盘操作：Ctrl+W) 关闭所有查看窗口(等价键盘操作：Ctrl+X) 数组排序及重复性判定(等价键盘操作：F8) 数组线性导入 …(等价键盘操作：F9) 等幂和次数：0～9999(=0时，求积) 等价键盘操作：[ Ctrl+ ][ Alt+ ] ←/→ (光标键) 数字千位分节符 显示值之位数（Max > 1,000,000,000） 数据显示窗口 阶数显示窗口 清空数组(等价键盘操作：Esc | Shift+Del) 等价键盘操作：Del 等价键盘操作：Bksp 清除存储区域中的数据。等价键盘操作：Ctrl+L 等价键盘操作：7 等价键盘操作：8 等价键盘操作：9 读取后台存储数据。等价键盘操作：Ctrl+R 等价键盘操作：4 等价键盘操作：5 等价键盘操作：6 存储当前显示数据。等价键盘操作：Ctrl+S 等价键盘操作：1 等价键盘操作：2 等价键盘操作：3 将显示数据加入存储数据中。 等价键盘操作：Ctrl+P | Ctrl+"+" 将显示数据乘进存储数据里。 等价键盘操作：Ctrl+M | Ctrl+"*" 等价键盘操作：0 平移数组使最小数为“0”。等价键盘操作： Alt+Bksp | Ctrl+"-" | Ctrl+Alt+"0" 等幂和计算(等价键盘操作：SpaceBar) 数组编辑窗口（冻结区） 数组编辑窗口（可编辑区） 可按 Home/End、PageUp/PageDown、↑/↓(光标键) 进行快速浏览；若同时按住 Ctrl 键，则可调整数据顺序。 另：拖动滑块，会自动提示最上端可编辑数据序号及数值。 注：本模块实现了“数据屏显位置保持”之特性。 新开一个 PowCalc (等价键盘操作：Ctrl+N) E-Mail：gxqcn@163.com 状态提示 日期 时间 始终在上？(等价键盘操作：Alt+T)
PowCalc V2002.12.08
界 面 指 引

（鼠标停留在不同区域将出现相应的提示，图案仅供参考）
备注： 该版本采用度身定制的仿 WinowsXP 自定义控件设计；在 XP 平台下还将实现真正的 XP 风格（包括系统弹出的 MsgBox）。

查看网上最新版本


功能简介

本“ PowCalc PowCalc”为研究“等幂和问题”而特制；
她可对超大非负整数（数组）进行快速、严格的“等幂和”计算。
适合于科学计算，尤其适用于数论研究。

其特色为：
  • 等幂和次数范围：0～9999次（=0时，求积）
  • 最大输入值位数：64位（十进位制）
  • 最大输入值个数：＞20亿个*
  • 最大输出值位数：＞1,000,000,000位*（十进位制）
  • 灵活而强大的输入、导出功能
注意*：仅受用户内存限制。

其快速算法由作者郭先强苦心研制而成！

运用其快速核心算法，作者为 [image] “自守数问题”（网上下载）特设计了一程序，可在 1s 内打破老外创造的“世界纪录”（该软件用VC++6.0开发，可直接运行于所有 Windows 平台）！


安装卸载

运行环境 & 安装卸载
  • 操作系统：Windows 95/98/ME/NT/2000/XP，简体中文平台

  • 屏幕分辨率：1024×768，小字体（推荐）

  • 若您的计算机已完全安装“ [image] PowCalc(等幂和计算器)”（前续版本），直接运行 [image] PowCalc.exe 即可

  • 精简安装：若您的计算机已完全安装 VC++6.0 or VB6.0 企业版，运行自解压精简安装包 [image] PowCalc_sfx.exe 即可
    （因为是自解压方式，反安装时直接删除安装目录即可）

  • 完全安装：运行 [image] PowCalc(等幂和计算器) V2002.12.08 安装程序 [image] PowCalc_setup.exe 即可

  • 卸载：安装包中自带卸载功能，可以从您的计算机上完全卸载 [image] PowCalc V2002.12.08


使用技巧

本计算器 PowCalc ，虽为全免费共享，但却完全按商业标准开发。

作为一款“计算器”，它首先应满足实用与便捷等特点，本计算器 PowCalc 在使用习惯上与大多数软件保持一致。

本计算器 PowCalc 设计理念中特别注重人机交互，其所有按钮、菜单均有相应快捷键支持，并浮动提示；还配有进度条、状态栏指示，使您适时了解状况；同时，本计算器 PowCalc 还具有强大的自动纠错功能。

本部分包括以下内容：
  • 快捷键帮助
  • 输入技巧
  • 计算技巧
  • 输出技巧
  • 关于存储
  • 格式转换
  • 特别提示


快捷键清单
快 捷 键 | 动 作
F1（or Shift+"?"） | 本计算器“ [image] PowCalc”的联机帮助
F2 | 将当前数组以“CR”换行符间开复制于剪贴板上
F3 | 将当前数组以“Tab”定位符间开复制于剪贴板上
F4 | 将当前数组以“逗号+空格”符间开复制于剪贴板上
F5 | 将当前数组以 HTML 表格格式复制于剪贴板上 …
F6 | 将当前数组以 Excel 表格格式复制于剪贴板上 …
F7 | 数组反向
F8 | 将当前数组升序重排，并判断有无重复数据及其重复次数； 如无重复，还可自动搜索“最小无重复系数”（当 n2≤999,999 时）
F9 | 数组线性导入 …
0～9 | 输入数据
Tab（定位键） | 切换数据显示窗口左右对齐方式
Shift+Tab | 切换数组编辑窗口数据左右对齐方式
Ctrl+Tab | 切换数组编辑窗口在主窗口中左右位置
Esc（取消键） | 清空数组
Del（删除键） | 删除当前在编辑数据
Shift+Del | 立即清空数组
Bksp（退格键） | 抹去当前编辑数据末尾数字（注：可屏蔽“替换”状态）
Alt+Bksp （Ctrl+"-" | Ctrl+Alt+"0"） | 归零（平移数组使最小数为“0”），并可使数组最简化
Ctrl+Ins（插入键） | 设置数组“智能粘贴”智能选项 …
Shift+Ins | 导入（或插入）“智能粘贴”数组
Enter（回车键） | 结束当前数据编辑，并继续编辑下一数据 （若当前数据在最后一行，将新增一默认值：0）
SpaceBar（空格键） | 等幂和计算（可随时点击窗口右上角“关闭”按钮 [image] 终止）
Ctrl+C | 将数据显示窗口中的数据复制到剪贴板上
Ctrl+D | 新开一个“ [image] PowCalc”，并复制备份当前数组
Ctrl+K | 将数据显示窗口中的数据与剪贴板上的比较
Ctrl+H | 折半合成计算 …
Ctrl+L | 清除存储区中的数据
Ctrl+M(or Ctrl+"*") | 将显示数据乘进存储数据里
Ctrl+N | 新开一个“ [image] PowCalc”（最多可达 255 个）
Ctrl+P(or Ctrl+"+") | 将显示数据加入存储数据中
Ctrl+Q | 搜寻最小无重复正交系数 …
Ctrl+R | 读取后台存储数据
Ctrl+S | 存储当前显示数据
Ctrl+T | 生成正交表 …（可选择 HTML/Excel 表格格式，是否自动添加行列序号等）
Alt+T | 切换“始终在上”模式
Ctrl+U(or Ctrl+"/") | 取模分解 …
Ctrl+V | 导入（或插入）“智能粘贴”数组
Ctrl+W | 将新开一窗口 [image] 输出：数组、结果、耗时、次数... （右击该窗口，有“复制”数据浮动菜单可供调用）
Ctrl+X | 关闭所有 [image] 子窗口
←（左箭头键） | 等幂和次数（循环）递-1
→（右箭头键） | 等幂和次数（循环）递+1
Ctrl+ ← | 等幂和次数（循环）递-10
Ctrl+ → | 等幂和次数（循环）递+10
Alt+ ← | 等幂和次数（循环）递-100
Alt+ → | 等幂和次数（循环）递+100
Ctrl+Alt+ ← | 等幂和次数（循环）递-1000
Ctrl+Alt+ → | 等幂和次数（循环）递+1000
↑（上箭头键） | 跳转至上一行数据
↓（下箭头键） | 跳转至下一行数据
PageUp | 跳转至前一页数据
PageDown | 跳转至后一页数据
Home | 跳转至首行数据
End | 跳转至末行数据
Ctrl+↑（上箭头键） | 移数据至上一行
Ctrl+↓（下箭头键） | 移数据至下一行
Ctrl+PageUp | 移数据至前一页
Ctrl+PageDown | 移数据至后一页
Ctrl+Home | 移数据至首行
Ctrl+End | 移数据至末行


输入技巧
  • 主键盘、小键盘键入 (0-9)

  • 点击相应按钮

  • 鼠标右击数字按钮，则结束当前数据编辑，并继续编辑下一数据（若当前数据在最后一行，则新增一数据，并取其默认值“0”）

  • 拉动网格线，可实现数据“冻结”功能（防止被编辑）或“解冻”功能

  • 双击数据编辑窗直接编辑 (支持 Ctrl+A、Ctrl+X、Ctrl+C、Ctrl+V 等快捷键，含有独创的“智能过滤”技术)

  • 数组反向 (F7)

  • 线性数列导入 (F9)：
    线性导入-A
    当前数组为空，或仅有一个元素时     		线性导入-B
    当前数组元素个数≥2时
    提示： 在“线性导入-A”前可先输入“首项”，最大可为 64 位；否则“首项”最大仅为 9 位

  • 数组智能粘贴导入 (Ctrl+V / Shift+Ins)
    “智能粘贴 选项”界面

  • 在当前位置插入一个数或一组数：可通过“插入"智能粘贴"数组”实现(Ctrl+V)

  • 读取存储（计算）数据 (Ctrl+R)

  • 重编辑时，默认为替换模式；可按“退格”键消除
    举例 如下：数组中已有一个数“1234567890”，现再次选中该数：
    ①、若紧接着按“1”，则：1234567890→1
    ②、若先按“退格”键，再按“1”，则：1234567890→123456789→1234567891

  • 按 ↑/↓、PageUp/PageDown、Home/End 可浏览数组；若同时按 Ctrl 键，则可调整数据顺序*
    注*： 本模块实现了“数据屏显位置保持”之特性


计算技巧
  • 按 Alt+Bksp 可进行“归零”运算：平移数组使最小数为“0”，并可使数组最简化（同时除以其最大公约数），这是本计算器 PowCalc 提供的可使数组元素变小的功能及途径之一（自 V2002.12.08 开始提供）；

  • 按 F8 将当前数组升序重排，并判断有无重复数据及其重复次数；
    如无重复，还可自动搜索最小无重复系数*（当 n2≤999,999 时）：
    最小无重复系数

  • 等差数列、等比数列可通过“线性导入-A”获得 (F9)
    线性导入-A
    提示：可用此功能实现阶乘、双阶乘运算

  • 对当前数组（元素个数≥2）线性变换可通过“线性导入-B”实现 (F9)
    线性导入-B

  • 可对当前数组“取模分解”(Ctrl+U)，这是本计算器 PowCalc 提供的可使数组元素变小的功能及途径之一（自 V2002.12.08 开始提供）；
    取模分解
    提示：此功能具有可多级分解之特点

  • 可将当前数组对折合成计算 (Ctrl+H)
    折半合成计算

  • 可将当前数组一分为二进行“搜寻最小无重复正交系数”计算* (Ctrl+Q)
    搜寻最小无重复正交系数

  • 可将当前数组一分为二进行“正交”计算* (Ctrl+T)
    构造正交表

  • 本计算器 PowCalc 在保证高速计算前提下，对系统资源占用却极小，即便对超大数组进行超级运算，也并不影响其它程序的同步运行（您甚至可继续听 MP3 或观看 VCD），且您也可随时取消当前的计算（按窗口右上角“关闭”按钮 [image] ）
注意*： 因要生成一个二维矩阵，可能需要耗用巨大的内存资源，请谨慎使用。


输出技巧
  • 直接读取数据显示窗口。当数据太长时，无法显示部分将用“…”代替，可通过“左对齐/右对齐”分别查看其“首/末”数字 (按 Tab 切换)

  • 按 Ctrl+C 复制到剪贴板上，即便是当出现显示“…”时也可全部复制（当复制内容≥64KB时，复制成功将发出消息）

  • 另开“查看结果”窗口 (Ctrl+W)（或点击 查看按钮 ）

  • 按 F2、F3、F4 之一可将当前数组向剪贴板以不同间隔格式导出
    浮动菜单
    提示： 若需将当前数组复制于Excel一列中，请按 F2；欲复制于Excel一行中，请按 F3

  • 按 F5 可将当前数组向剪贴板以HTML格式导出*
    设定参数

  • 按 F6 可将当前数组向剪贴板以Excel格式导出*
    设定参数

  • 快速复制备份当前数组：新开一个“ [image] PowCalc”，并复制备份当前数组(Ctrl+D)

  • 本计算器 PowCalc 在设计时还参考了有关论文写作标准，数字千位分节符有三种模式可选，使您无须作任何后处理，即可将数据直接粘贴进您的论文中

  • 本计算器 PowCalc 还特设了“数据校对”功能(Ctrl+K)，使您可快速判断两个数据是否全等*
    注意*： 为得到正确结果，请将两个校对数据设定相同的“数字千位分节符”输出模式

  • 数据显示窗口的背景颜色将与最后一次运算的按钮颜色一致

注意*：生成的剪贴板上有主页、email、UserName等信息，您可以用 regedit.exe（注册表编辑器）进行编辑（否则系统会自动读取默认值），位置在：HKEY_LOCAL_MACHINE\SOFTWARE\GxQ MathTool Studio\PowCalc，相关截图如下：


关于存储
支持存储运算，是从 V2002.08.15 开始的。

该功能可实现对显示数据（可以是超级数据）进行存储、与存储数相加/相乘等运算，并巧妙地避开了“输入位数≤64”的限定。
  • 按 存储当前显示数据。等价键盘操作：Ctrl+S 可对显示窗口中的数据（非零）进行存储

  • 按 将显示数据加入存储数据中。等价键盘操作：Ctrl+P 将显示数据（非零）与存储区的数据相加，其结果并不显示，但更新当前存储数据

  • 按 将显示数据乘进存储数据里。等价键盘操作：Ctrl+M 将显示数据（非零）与存储区的数据相乘，其结果并不显示，但更新当前存储数据

  • 按 读取后台存储数据。等价键盘操作：Ctrl+R 读取后台存储数据
    状态提示栏将提示存储运算的“历史回溯”Trace：
    “S”代表MS
    “+”代表M+
    “*”代表M*
    “…”代表显示数据（可能）曾经编辑
    “R”代表MR

  • 数据显示窗口的背景颜色将与最后一次运算的按钮颜色一致


格式转换

通过本计算器 PowCalc 强大的输入、输出功能，借助最新研发的数字智能提取技术，您可轻松实现 .txt、.xls、.doc、.htm 等文本格式的相互转换。并且不生成任何临时文件，一切仅通过剪贴板实现——这是本计算器 PowCalc 格式转换的特色之一。

流程如下：
  • 输入：技巧

  • 计算：技巧

  • 输出：技巧

    （注：以上步骤并非必须。在某些时候，甚至不需作任何计算，仅输入/输出即可）

  • 当导出为 HTML、Excel 格式时，系统会自动将用户名写入“作者”栏中，取值模式优先级顺序如下：①自动提取安装“ [image] PowCalc”时键入的“姓名”；②自动提取计算机的注册用户名；③若以上皆失败，则为“(your name)”


特别提示
  • 本计算器“ [image] PowCalc”在 V2002.12.08 之前的曾用名为“ 等幂和计算器 等幂和计算器”

  • 本计算器按 Ctrl+N 可新建一个 PowCalc （最多可达 255 个）

  • 最小化某个 PowCalc ，其相应的所有 [image] 窗口将自动隐藏（如果有的话）

  • 还原某个 PowCalc ，其相应的所有 [image] 窗口将同时还原（如果有的话）

  • 关闭某个 PowCalc ，其相应的所有 [image] 窗口将同时关闭（如果有的话）

  • 本计算器 PowCalc 当重复加载实例时，会自动判别并防止重载：自动还原先前所有的“ [image] PowCalc”并自动激活其中之一

  • 本计算器 PowCalc 当设置“始终在上”时，其上的 ToolBar 可能不会显示 ToolTip，取消（按状态栏右下角图标按钮 始终在上？(等价键盘操作：Alt+T) ）即可显示

  • 如果计算量很大，按 PowCalc 窗口右上角“关闭”按钮 [image] ，随时可取消当前的计算

  • 本计算器的EXE执行文件 PowCalc 与CHM帮助文件 帮助 需在同一级目录下；且主文件名需相同（如果您需要对它们更名的话）

  • 本计算器 PowCalc 某些功能可用在幻方的设计中


郑重申明
  • 本版本为免费共享版，是作者献给广大数学爱好者的一份薄礼。任何人可以自由且免费的使用该软件，并拷贝及散布给他人，不必为此支付任何费用，使用上不会出现任何日期的限制或是软件使用上的限制

  • 严禁用于任何商业目的

  • 警告：本计算机软件受著作权法和国际公约的保护。未经作者授权，不得对本软件作任何修改，不得对本软件进行逆向工程、反汇编或解体拆卸，否则将视作侵权行为，将会导致严厉的民事和刑事惩罚，并将受到法律允许范围内的最大限度的起诉。


请与作者联系
江苏省苏州市苏锦一村锦月新居132-202室(215031) 郭先强（收）
见主页（包含办公电话等，及时方便有效）；或留言
gxqcn@163.com; HugeCalc@Gmail.com
http://www.emath.ac.cn/
http://bbs.emath.ac.cn/

作者主要发展方向：
数论、组合数学等；

感兴趣的课题：
等幂和问题、幻方，有关整数（矩阵）的快速算法研究，组合优化，组合中的快速构造及存在性计数问题等。

如果您在使用过程中，有不满意的地方，敬请来电来函批评指正！

如果您比较满意本系统，也请您与作者联系，以资鼓励。

在数学研发论坛上，欢迎您就本人原创软件提出批评或建议，

也欢迎您就当前的数学研究和发展，及计算机在数学研究中的应用，提出您的高见！

作者还有许多数学应用程序，愿与大家共享之 … …